A Audio and hi-fi forum. AudioBanter

Go Back   Home » AudioBanter forum » rec.audio » Pro Audio
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUG BUG !!!



 
 
Thread Tools Display Modes
  #1  
Old January 5th 19, 08:18 PM posted to rec.audio.pro
[email protected]
external usenet poster
 
Posts: 39
Default Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUG BUG !!!

I connected pretty much everything as described he

https://www.creative.com/oem/resourc...rds/sb046x.pdf

And all connections connected to the proper inputs on the denon receiver 1909.

I am not sure about the subwoofer/side left connections.

There are two configurations possibly.

1: Subwoofer sound goes to SIDE LEFT.

2: Swapping them: No sound.

The subwoofer is missing though, perhaps the denon receiver detects this ?

But it's more likely a weird situation in windows 7.

"Configure Speakers"

Instead of simply asking the user what kind of system is connected.

It does something stupid like:

Large speakers/subwoofer present yes/no

Depending on the answers giving windows re-assigns the outputs/jacks etc.

This is driving me crazy.

Or it could simply be a bug in windows 7/audio stack or creative drivers.

Somehow the left side and subwoofer channel is swapped ?!

Unless goldwave is buggy or a test file is buggy.

I will upload test file so anybody out there with a 7.1 surround sound system connect to windows 7 can test it out if you like too.

Or at least check if file is correct.

I have a 7.0 surround sound setup ?! So how the **** should I setup these ****ty speakers in windows 7 ?!

If I tell windows the subwoofer is missing... then it will play the subwoofer sound via something else it seems... which is very weird.

Basically I hate this speaker configuration bull**** in windows 7, it's super ****ing weird.

HERE IS MY QUESTION:

How to re-assign speaker outputs without THX setup console ?!?!?!?!?

IS there perhaps a registry hack for creative tech or windows 7 ?!?

So I don't have to install this thx setup console ?! I can do that... but still... shouldn't be necessary.

Perhaps need to use 7 channel file or so ? Or disable subwoofer channel... don't think this is necessary though... hmm weird.

Test file is he

Folder:

http://www.skybuck.org/Media/Sounds/...round%20Sound/

Direct link to test file:

http://www.skybuck.org/Media/Sounds/...Channel_ID.wav

Seems like somebody at microsoft/creative did some really sloppy testing and ****ed things up...

Or my denon receiver swaps channels on detection basis or something... or maybe I should disable subwoofer on it...

Very strange.

When subwoofer was disabled swapping left side/subwoofer connections didn't even help... the signal would still be played on other speakers... but that is probably misconfiguration by windows... it re-channels subwoofer to front speakers.

Currently configuration is:

All optional speakers checked v

Full range speakers checked v

Result is: Left side/subwoofer channels swapped or no sound at all if connections swapped.

I will try one more setting:

Currently configuration is:

All optional speakers checked v

Full range speakers unchecked.

Same result.

I know pretty much 100% sure some strange bug is now in windows simply because I disconnect front left/front right and rear left, rear right and side right cables (two of them).

So only 1 cable is connected which should be producing center, side left and subwoofer...

But clearly side left and subwoofer are swapped on speakers ? WTF ?!

There is no subwoofer connected.

The LFE channel is playing through the SIDE LEFT ?!

WHHHHYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY YYYYYYYYYYYYYYYYYY ?!

Perhaps bug in creative labs audio driver ?!?!?!?!?!

SIGH.

All creative labs drivers were removed and only a fresh web release installed !

This is default configuration !

I will try one more test:

subwoofer disabled in speaker configuration in windows 7:

NO SOUND.

I ll try swapping cables see if that matters.

NO SOUND.

One last thing I could try is not connect one of them

Re-enabling subwoofer

Only side left connected

Anyway I am done with testing...

It's pretty clear to me that somebody ****ed this up in the driver settings or in windows.

IT'S A ****ING BUG SOMEWHERE/WRONG SETTING.

****ING IDIOTS.

TEST PROPERLY !

Also way to many configuration possibilities/options reassignments in all of these softwares.

Keep things simple oh well.

I would not be surprised if there is a registry entry somewhere already searching for it. "Creative Tech" might turn up something.

Bye for now,
Skybuck.
Ads
  #2  
Old January 5th 19, 08:44 PM posted to rec.audio.pro
[email protected]
external usenet poster
 
Posts: 39
Default Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUGBUG !!!

I did come across audio objects in the registry editor so perhaps a configuration issue is there.

However I also come across some more interesting things:

A guy claiming that this tool might could be used to swap audio channels via a text file... I think this tool probably installs some driver/filter... doesn't work for asio and other more direct sound apis but it might help some out the

The software in general seems kind interesting... apperently it can do some effects or channel mixing or something not sure exactly what this is yet:

1. equalizer apo

https://sourceforge.net/projects/equalizerapo/

2. Description from Microsoft:

https://docs.microsoft.com/en-us/win...t-architecture

For now I will first try to get as much of creative x-fi software working by carefully installing via web release and then updating from that as much as possible and only install missing components from original cd/nero image.

I am starting to wonder if maybe the nero image has bit errors.

Or if the installation program has a race condition where installing from harddrive happens to fast... because dvd/cd was much slower.

So this might be a problem with deamon tools... it does not slow down the harddisk enough to make a true virtual cd/dvd drive behave the same as a real one.

Bye for now,
skybuck.
  #3  
Old January 5th 19, 08:49 PM posted to rec.audio.pro
John Williamson
external usenet poster
 
Posts: 1,595
Default Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUGBUG !!!

You mention you have a 7.0 playback system with no subwoofer. Is this
correct?

If so, then you will find differences in channel allocations when
decoding the file if it is encoded for a 7.1 system.

--
Tciao for Now!

John.
  #4  
Old January 7th 19, 05:15 AM posted to rec.audio.pro
geoff
external usenet poster
 
Posts: 1,403
Default Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUGBUG !!!

On 6/01/2019 8:18 AM, wrote:
> I connected pretty much everything as described he


Dunno, but find it suspicious that all these odd things tend to happen
to you, and nobody else in the world appears to have noticed this.

geoff
  #5  
Old January 7th 19, 11:52 PM posted to rec.audio.pro
Nil[_2_]
external usenet poster
 
Posts: 242
Default Why is side left and subwoofer swapped for 7.1 in windows 7 ? BUG BUG !!!

On 06 Jan 2019, geoff > wrote in
rec.audio.pro:

> On 6/01/2019 8:18 AM, wrote:
>> I connected pretty much everything as described he

>
> Dunno, but find it suspicious that all these odd things tend to
> happen to you, and nobody else in the world appears to have
> noticed this.


You wouldn't be suspicious if you had witnessed him in action in other
newsgroups. He's a genuine kook.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Interesting Subwoofer Side Effect Gary Eickmeier High End Audio 16 December 4th 11 03:37 PM
Side by Side Comparison..Ipod Shuffle, Creative Zen Nano, IRiver T 30 jim Audio Opinions 3 November 3rd 05 04:14 PM
Left side audio problems in an '01 Mustang [email protected] Car Audio 0 January 7th 05 10:12 PM
FA: dbx 118 & dbx 128 vintage comps racked side by side Kevin Kelly Pro Audio 0 December 27th 04 05:33 AM


All times are GMT +1. The time now is 01:00 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 AudioBanter.
The comments are property of their posters.